Hi,
the PVID setting X of a port is for ingress traffic and defines the VLAN (=X) an incoming untagged ethernet frame will be assigned.
For egress traffic via that port this corresponds to the port being set to be an untagged member of the same PVID VLAN value X (a frame internally tagged with VLAN X will be sent untagged, when leaving the switch via a port that is an untagged member of VLAN X)
Both settings together correspond to a Cisco access port configured for VLAN X or to a Cisco trunk port configured for VLAN X to be the native VLAN:
interface e1/1
description - access port for VLAN X
switchport access vlan X
switchport mode access
interface e1/2
description - trunk port, native VLAN X
switchport mode trunk
switchport trunk native vlan X
switchport trunk allowed vlan X,...
Any port can be an untagged member of a single VLAN only.
But a port can be a tagged member of one or more VLANs. And tagged membership is symmetric, that is it covers both ingress and egress.
If a port is a tagged member of VLAN Y, egress frames will be sent tagged with VLAN Y and ingress frames are only accepted, if they are tagged with VLAN Y (otherwise they will be dropped).
For your scenario I'd suggest, that you configure the mustard ports at your Cisco switch to be trunk ports with native VLAN 1 as follows:
interface ...
switchport mode trunk
switchport trunk native vlan 1
switchport trunk allowed vlan 1,90
The mustard ports at your DGS switches then must be configured as follows:
PVID = 1 (=default)
untagged member of VLAN 1 (=default)
tagged member of VLAN 90
The red ports must be configured as follows:
PVID = 90
untagged member of VLAN 90
The green ports must be configured as follows:
PVID = 1 (=default)
untagged member of VLAN 1 (=default)
PT